Home > Support > Xbox 360, Kinect and Accessories > USB device doesn’t work when connected to an Xbox 360 console

USB device doesn’t work when connected to an Xbox 360 console

Overview

A device connected to a USB port on the Xbox 360 console doesn't work or doesn't work as expected. Or, when you connect a device to a USB port on your Xbox 360 console, the device may not be detected as expected. Therefore, you cannot use the device.

Read this page to learn more about this issue and what you can do to resolve it.

On this page

Cause

This issue may occur for one or more of the following reasons:

  • The device is not compatible with Xbox 360.
  • The USB cable isn't connected correctly.
  • The USB cable is faulty.
  • The USB device was not recognized during console startup.
  • The USB device requires an external power supply that isn't present.
  • The USB device is faulty.
  • The USB port on the Xbox 360 console is temporarily disabled by the over-current protection mechanism.
  • The USB port on the Xbox 360 console is faulty.

Solution

To resolve this issue, use the following methods.

Note Test your USB device after each method to see if the device works. If a method doesn't resolve the issue, go to the next method.

Method 1: Verify that the device is compatible with Xbox 360

Verify that the portable device is compatible with Xbox 360. The following devices are compatible with the Xbox 360 console:

  • Official Xbox 360 accessories
  • Most USB mouse devices and USB keyboards
  • Most digital cameras
  • Many portable music players
  • Many mass storage devices

Note For more information about how to use a USB flash drive as a memory unit on your Xbox 360 console, see USB flash drive support for Xbox 360.

Method 2: Troubleshoot the USB device

If the USB device is compatible with Xbox 360, troubleshoot the USB. To do this, follow these steps:

  1. Restart the Xbox 360 console.
  2. Disconnect the device from the USB port, and then turn off the console. After 5 to 10 seconds, turn the console back on. After the console has restarted, reconnect the device to the USB port.
  3. Turn off the console, remove the power cord from the power outlet, reconnect the power cord, and then turn on the console again.
  4. Disconnect any unnecessary devices from the console.
  5. Determine whether the USB device requires a separate power supply. If it does, attach the power supply.
  6. Connect the USB device to a different USB port on the console and see whether the device works. If the device works in another USB port, the Xbox 360 console may require service.

Note If these steps didn't resolve the issue, the Xbox 360 console may require service. Start the repair process online.

More Information

Each USB port on the Xbox 360 console is protected by an over-current protection mechanism to reduce the risk of damage. An over-current situation may occur if the USB device that is attached to the Xbox 360 console tries to draw too much power from the USB port. In these situations, the USB port will temporarily turn off to prevent damage. The USB port will reset after the device is disconnected.

Related Issues

To provide better support, did this solution solve your problem?

Yes
No

Thank you for your feedback

Thanks for Your Feedback

Thank you for taking the time to send us your comments and suggestion about this article. Your feedback is important for us to improve our service.

Provide feedback on this page

Was this information relevant? What can we do to improve this information?
To protect your privacy, do not include contact information in your feedback. 0/255 characters

Assistance

forum.png Xbox Support Forums

Get help from the knowledgeable Xbox Community and official Xbox Support!

 
ambassador.png Chat with an Ambassador

Connect to other Xbox customers like you who know their stuff and want to help.

 
contact_us.png Contact Us

Get in touch with an Xbox Support technician. We are ready and willing to help you!

Contact Us

Would you like to contact Support regarding the "USB device doesn’t work when connected to an Xbox 360 console" issue you were reading about or a different issue?