Problems connecting to Xbox Live from a Games for Windows LIVE game

Overview

This article describes what to do if you experience connectivity issues when you try to connect to Xbox Live from a Games for Windows LIVE game.

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Symptoms

When you try to connect to Xbox Live from a Games for Windows LIVE video game, you experience connectivity problems.

Cause

This issue can occur if there’s more than one network adapter installed on the computer.

Resolution

To resolve this issue, use the following methods. If a method does not resolve the issue, go to the next method.

Method 1: Configure the correct network adapter

Windows Vista, Windows 7, and Windows 8

To resolve this issue on a computer running Windows Vista, Windows 7, or Windows 8:

  1. Set the correct network adapter as the preferred device. To do this follow these steps:
    1. Click Start or open the Start screen, type ncpa.cpl in the Start Search box, and then press Enter.
    2. Press the ALT key on the keyboard.
    3. On the Advanced menu, click Advanced Settings.
      Note If you are prompted for an administrator password or confirmation, type the password or click Continue.
    4. On the Adapters and Bindings tab under Connections, click the up or down arrow buttons to change the order of connections to the order that you want.
  2. Disable the network adapters that you do not want to use. To do this, follow these steps:
    1. Click Start or open the Start screen, type devmgmt.msc in the Start Search box, and then press Enter.
    2. Expand Network adapters.
    3. Right-click each adapter that you do not want to use, and then click Disable.

Windows XP

To resolve this issue on a Windows XP-based computer, follow these steps:

  1. Set the correct network adapter as the preferred device. To do this, follow these steps:
    1. Click Start, click Run, type ncpa.cpl, and then click OK.
    2. On the Advanced menu, click Advanced Settings.
    3. On the Adapters and Bindings tab under Connections, click the up or down arrow buttons to change the order of connections to the order that you want.
  2. Disable the network adapters that you do not want to use. To do this, follow these steps:
    1. Click Start, click Run, type devmgmt.msc, and then click OK.
    2. Expand Network adapters.
    3. Right-click each adapter that you do not want to use, and then click Disable.

Method 2: Check the service status

A service may be down. This problem may prevent you from accessing Games for Windows LIVE or signing in. To check the status of the servers, see Service status.

Note If you cannot connect to the Service status website, contact your Internet service provider for help.

Method 3: Verify that you are in a LIVE-supported locale

To connect to Games for Windows LIVE, you must be located in a supported Games for Windows LIVE locale. Games for Windows LIVE is not available in all countries. For more information, see Xbox Live countries and regions.

Method 4: Install the latest Games for Windows LIVE software

To sign in to Games for Windows LIVE, you must have the latest update to the program installed. Download the latest Games for Windows LIVE setup files.

Note Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Method 5: An error occurred during sign-in

For more information about a specific error message that occurred during sign-in, see Troubleshoot Xbox Live sign-in problems.

Method 6: Verify that your router is compatible with Games for Windows LIVE

To connect to the LIVE service as easily as possible, we recommend that you use a router that is on the Windows Compatible Hardware list. To check the list, visit the Compatibility Center.

Note If your router is not on this list, the router may be incompatible with Games for Windows LIVE.

Method 7: Enable UPnP

UPnP must be enabled for you to connect to LIVE. UPnP IGD (Internet Gateway Device) protocols are supported by most routers and firewalls today. However, these settings are not always enabled by default. For help, see the owner's manual or the Help files, or contact your network administrator.

Commercial firewalls, such as those typically at universities, libraries, and corporations, do not typically support UPnP IGD specifications. Gamers who try to play from school or a dorm room may be unable to connect to LIVE. If you can’t, contact the IT administration office to see whether they can enable LIVE for the network.

Method 8: Clear the Internet cache

Make sure that you are viewing the latest version of pages by clearing the Internet cache.

To do this on a Windows 7-based computer, follow these steps:

  1. Close any Internet browser windows that are open.
  2. Click Start, and then click Control Panel. If the Control Panel window is empty, click View all Control Panel Options in the navigation section of the window to display all the icons.
  3. Click Network and Internet and then click Internet Options.
  4. In the Browsing history section of the General tab, click Delete.
  5. Click to select the Temporary Internet files and Cookies checkboxes, and then click Delete.

Method 9: Open the ports for Games for Windows LIVE

Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

The following ports must be open for in-bound and out-bound connections to work for Games for Windows LIVE:

  • TCP port 3074
  • UDP port 88
  • UDP port 3074

For information about how to configure port settings on a firewall, router, or gateway, see the documentation that was included with the device, or contact the network administrator or local technical support for help.

For more information about how to set up a firewall to work with a Games for Windows LIVE for Windows-based computers, see Set up a Windows Media Center Extender.

If you are still experiencing connection problems to LIVE, you must configure your router or gateway device to enable UPnP or port forwarding.

If your router supports UPnP, this feature should be enabled. It is designed to handle Network Translations so that port forwarding is not required.

For more information about how to verify compatible home networking devices, see the Xbox Live compatible hardware list.

Notes

  • This article provides a link to a list of LIVE-supported routers that have UPnP feature functionality. Unfortunately, not all routers support UPnP. If your router does not support UPnP, you will have to open these ports and map them to the IP address of the computer that is running Games for Windows LIVE.
  • If you have questions on how to enable UPnP or port forwarding on your router or gateway device, we recommend that you contact the hardware manufacturer for help.
  • If your network is set up to use IPv6, read the recommendations for an IPv6 feature set for home routers that are compatible with the Microsoft Windows family of operating systems.

Method 10: Allow Games for Windows LIVE through a firewall

Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

Note Do not open a port for a program that you do not recognize.

You may have to configure an exception in your firewall, proxy, or Internet Security software to allow the Games for Windows LIVE software (GFWLClient.exe) to work. By default, this file is saved in the following location:

C:\Program Files\Microsoft Games for Windows LIVE\Client

If you use Windows Firewall, the latest installation of the Games for Windows LIVE update will give you the option to add the software to your exceptions list. Otherwise, see the documentation that was included with your firewall, or contact the network administrator or local technical support for help.

For more information, see Network ports used by Xbox Live.

Method 11: Install the latest service pack for Windows

Games for Windows LIVE requires the latest service pack for Windows. To obtain the latest service pack for your version of Windows, see Support for Microsoft Service Packs.

Method 12: Troubleshoot your Internet connection

Your computer may be experiencing Internet connections issues. To help resolve these issues, run the Internet Connectivity Evaluation Tool. To run this tool, visit Get to know Windows.

If you are using Windows Vista or Windows 7, see the Troubleshoot Internet connection problems.

Method 13: Contact your Internet service provider

If the previous steps have not resolved the problem, contact your Internet service provider for more help.

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